Koen Vosters

There is always a point in sharing.

Could not load type ‘Microsoft.AnalysisServices.SharePoint.Integration.ReportGalleryView’

If you ran into this issue, the first thing you need to do is check if the PowerPivot solution is deployed to the web applications. You  can do this by going to Central Administration > System Settings > Manage Farm Solutions and there you should see the solution powerpivotwebapplication.wsp. Make sure it is deployed to… Read more

Distributed Cache Service cannot be started

Today we ran into an interesting problem. The distributed cache service was no longer working. As it was a single server environment, we removed the service instance and reprovisioned it following: http://technet.microsoft.com/en-us/library/jj219613.aspx Strangely, it refused to start and went back to the services page. In the end, the following powershell fixed the distributed cache (after… Read more

CRM 2013 : Microsoft.Crm.SharedSetup.SetupException: The XML in the configuration file is not valid.

After testing our CRM 2013 installation scripts on our own environments, we decided to deploy them on the customer’s environment. As we were to expect a standard windows environment with IIS installed, we used the scripts we tested on identical environments. When we ran our scripts, we experienced the following error: Microsoft.Crm.SharedSetup.SetupException: The XML in… Read more

CRM 2013 Unattended Install: Backend Installation: Check WebServerValidator: The Website does not exist.

It took a while to figure this one out, given that I am not a CRM specialist. If you define that the backend server contains the DeploymentWebServiceRole, you also need to define the WebsiteUrl parameters in the xml file. If you don’t, you will get the above error that doesn’t really explain that it is… Read more

AutoSPInstaller: The local farm is not accessible. Cmdlets with FeatureDependencyId are not registered.

During the weekend I started setting up a new dev environment on Windows Server 2012 R2. I used SQL Server 2012 and installed everything in the easy dev box setup mode (meaning all running under one account). I had the local farm is not accessible error message, even though all permissions were granted. After some reseach, I found out… Read more

Sorry, this site hasn’t been shared with you – Host Named Site Collections

So, Host Named Site Collections are the new thing. You’ve created your web application and created a host named site collection through PowerShell. You browse to the site and it renders nicely. Yet when you expect to see the site, you get the standard SharePoint screen which tells you that you don’t have access to… Read more

Dell XPS12 : Wireless network not showing any networks

I recently got a Dell XPS12 device as my new laptop at work. I like the device a lot, especially since I am travelling by plane a lot lately. Today, for some reason, the wireless network did not detect any networks. Other devices had no problem detecting all the wireless networks, but the Dell just… Read more

The Subscription Settings service and corresponding application and proxy needs to be running in order to make changes to these settings.

  This is the nice screen I got when I wanted to finalize the configuration of a blank SharePoint 2013 development environment at the customer that was already “partially prepared”. Even if I was quite sure I checked those to see if they were running. I checked again: Looking in the Manage Services Screen: Going… Read more