File or arguments not valid for site template while creating SharePoint 2013 site collection using SharePoint 2010 site template

If you are trying to create site collection in SharePoint 2013 using SharePoint 2010 site template, then you need to provide CompatibilityLevel in New-SPSite cmdlet. CompatibilityLevel  specifies the version of site template to use when creating the site collection using New-SPSite. The values for CompatibilityLevel  can be either 14 for SharePoint Server 2010 experience sites…