Visual Studio 2015 Update 3 がインストールされた環境で VSIX パッケージのアップグレード インストールに失敗する問題について


こんにちは。Visual Studio サポート チームです。

今回は、先日リリースされた Visual Studio 2015 Update 3 で確認された VSIX パッケージのインストールに関する問題と対処方法についてご案内します。

(追記 : 2016 年 9 月 15 日)
本問題の修正を含む更新プログラムが米国時間の 2016 年 9 月 14 日にリリースされています。
更新プログラムは本稿末尾に記載のある MSDN ライブラリのドキュメント内の “manual download and installation” から入手してご利用いただけます。

 

現象

Visual Studio 2015 Update 3 がインストールされた環境で、VSIX パッケージをアップグレード インストールしようとすると以下のようなエラーが発生し、インストールに失敗する場合があります。

 

080416_1258_VisualStudi1.jpg

 

原因

本エラーは Visual Studio 2015 Update 3 における Extension SDK のバージョン管理の問題に起因しており、以下の条件を満たす場合に発生します。

・Visual Studio 2015 Update 3 がインストールされている。
・VSIX パッケージのインストール タイプが Extension SDK である。
・対象の環境に、同パッケージの古いバージョンが既にインストールされている。

 

対処方法

本エラーが発生した場合は、一度、古いバージョンの VSIX パッケージをアンインストールしてから、新しいバージョンの VSIX パッケージをインストールしてください。

なお、本問題は Visual Studio 2015 Update 3 用の次期更新プログラムでの修正が検討されています。
更新プログラムのリリース時期は現時点では確定していませんが、更新プログラムに関する情報は以下のドキュメントからご確認いただけます。

 

Update for Microsoft Visual Studio 2015 Update 3 (KB3165756)
https://msdn.microsoft.com/en-us/library/mt752379.aspx

 

弊社製品の不具合でご迷惑をおかけし誠に申し訳ありません。本エラーが発生した場合は上記の対処方法をご利用ください。

Skip to main content