Server Unavailable, Page Cannot be displayed after reinstalling IIS 6 on W2K3 SP1


Today I'd like to cover another issue that I have seen quite a few times in the past several weeks and one that has a very simple fix.  The problem is that IIS will not serve ASP and ASP.NET pages after reinstalling IIS.  The error that I most frequently see is "Server Unavailable" but it can also show up as "Page Cannot be Displayed".  Browsing regular .htm pages works fine and a check of the Web Service Extensions in IIS Manager shows that ASP and ASP.NET are both installed and enabled.  The problem typically occurs after users decide to reinstall IIS to "fix" some other unrelated issue on their web server.  I have seen this one frequently occur when users in a last ditch effort, have reinstalled IIS after having problems with Outlook Web Access. 


The issue is cause by a the installation of "mismatched" dlls when the reinstall occurs.  Typically during the installation of IIS, the installer will prompt for some additional files from the install media.  If the RTM (release to manufacturing a.k.a your original Windows install disk) is used instead of the SP1 media for this, the wrong versions (RTM instead of SP1) of several important dlls will be installed.  This breaks ASP pages and causes the issue.  A quick check of the properties of w3core.dll in the %SystemRoot%\system32\inetsrv folder will let you know if you are in this broken state or not (see screen shot below).  If your version of w3core.dll is 6.0.3790.0 then you are running the RTM version and you have a mismatched dll.  Windows 2003 SP1 should have a build of 1830. 



As you can see in the screenshot above, this machine has the correct version of w3core.dll. 


The resolution for this issue is simple.  Reapply SP1 and reboot the server. After this has completed ASP and ASP.NET pages should serve correctly.  Another quick check of w3core.dll should show confirm that we know have the right version of the dlls.  For more information on this issue, visit the KB link below. 


907275 IIS fails to serve ASP pages after you install IIS on Windows Server 2003 Service Pack 1
http://support.microsoft.com/default.aspx?scid=kb;EN-US;907275

HTTP/1.1 200 OK


Skip to main content