如何 5 秒內判斷 SQL Server 是否需要更新修正程式才支援 TLS 1.2


情境:

程式連結 SQL Server 時會出現錯誤訊息:

    例外類型: SqlException

    例外訊息: 與伺服器的連接已成功建立,但在登入程序時發生錯誤。 (provider: SSL Provider, error: 0 - 用戶端和伺服器無法溝通,因為它們沒有公用的演算法。)

判斷方式:

SQL Server 2014 SP2 (12.0.5000.0) 或是更新版本即支援 TLS 1.2 , 無需要安裝修正程式.

另外需要安裝修正程式的資訊請參考:

https://support.microsoft.com/zh-tw/help/3135244/tls-1-2-support-for-microsoft-sql-server



Enjoy. Jacky

 

Comments (0)

Skip to main content