Visual Studio 2008 – 支援多.NET Framework 版本開發


每當一個新版本的開發工具要推出時,許多朋友都會想要使用好用的新功能,但又擔心程式要升級的問題。這次不用太擔心這個問題,因為 VS 2008 除了可以同時與 VS 2005同時安裝在同一台機器外,Visual Studio 2008在單一開發工具中同時支援 .NET Framework 2.0、3.0及3.5的開發,在選擇要基於那個 .NET Framework版本後,會自動顯示該版本可以使用的專案範本、工具箱、可參考的內容及 IntelliSense等,如下圖:

image 

在 .NET Framework 2.0 的專案中,.NET Framework 3.0 及 3.5 版的元件會灰色。

image

 

且在一個方案中,也可以同時開發不同 .NET Framework 版本的專案,如下圖。這讓我們可更彈性的來規劃我們程式的升級或移轉的策略。

image

筆者的環境為 Vista + Visual Studio 2005 Team Suit SP1 + Visual Studio 2008 Team Suite

Skip to main content