July IE Expert Zone Chat


It’s that time again! Members of the IE team will be online for an Expert Zone chat this coming Thursday, July 13th at 10:00AM PDT (5:00PM GMT). These chats are great opportunities to have your questions answered and hear from members of the IE product team. A transcript will be published after the chat and transcripts of other recent chats are available.

These chats are lots of fun and we hope you will join us for the chat if you can.

Cheers,
Uche Enuha
Program Manager

Edit: Added the hyperlink to the chat.

Comments (32)

  1. Uche,

    Where is the link to where they will be online?  I’m having issues with my Beta 3 install.

  2. Fiery Kitsune says:

    I’ll probably be able to make this one…

  3. Ray says:

    Well umm ok, if that’s like 5pm GMT, then 8hrs ahead of 5pm GMT would be 1am, so like, i’m asleep at that time, grrrr, perhaps you guys could actually do it at an earlier / later time to allow other people in lots of different timezones to be able to attend them??? i for one would like to but i can’t since i would be half asleep at the keyboard…

  4. EricLaw [MSFT] says:

    @Ray: Sorry you’ll miss it– Unfortunately, no matter what time we pick, it’s in the middle of the night somewhere.

    Feel free to send any questions along to the blog and we can try to answer them here.  

  5. anphanax says:

    Are you guys planning on adding CSS 2.x’s "inline-block" support to IE 7.5/8.0 (whatever is next)?

    Opera has it, Firefox 1.5.0.4 (although a semi-hackish ‘display: table-cell’ works the way i’de like in both Opera and Firefox, where-as firefox seems to ignore it for say, spans and divs).

    I don’t know if i’ll be able make the chat, that’s why i’m asking now :.

  6. Ray says:

    Perhaps IE7 could have full CSS 2.0 support, mostly because even when IE7 comes out, a lot of people might look at it and think ‘meh!, Firefox has better CSS 2.0 support than this’ which means, even though you guys have added some stuff, essentially you haven’t made IE7 the BEST browser to use since it still lags behind on a lot of things.

  7. Patrick Stephens says:

    Can’t make the chat — but I’m wondering if there’s any chance that IE7 will change the Find feature before final release?

  8. ie6better says:

    Unfortunately, IE7 (beta 3) has lost freedom

    Here are some points I found today that IE7 can’t, while IE6 can.

    can not move the position of forward button

    can not move the position of back button

    can not move the position of address bar

    can not change the lengh of address bar

    can not move the position of reload button

    can not remove the reload button

    can not move the position of stop button

    can not remove the stop button

    can not move the search bar

    can not remove the search bar

    can not move the position of link bar

    can not move the position of menu bar

    can not move the position of favourite button

    can not move very much the position of command bar

    (it always stays on the same line, no going up)

    (Let me know if I am wrong.)

    If you want to use the menu bar, address bar, link bar

    and other buttons like favourites, print, home, you can put

    them on just two lines for IE6, but now IE7 requires at least

    three lines, so if you want to use like IE6, your screen will be

    actually smaller in IE7.

    As a user of IE6 and Firefox (from the begining), I know

    that IE7 learned a lot from Firefox. I won’t say it’s bad, but

    what I am really disappointed is that to get closer to Firefox,

    IE7 has lost freedome that IE6 used to have.

    I was using IE6 as a main software because Firefox does

    not allow my arrangement, but because IE7 is just like Firefox,

    I am looking for third party softwares.

    I hope anyone talks about this topic.

  9. Henry says:

    Can you please announce these chats more than 2 days in advance!?

    Many of us would like to participate, however with no advanced warning it is near impossible to clear our schedules!

    Thanks.

    Hen.

  10. ieblog says:

    @Hen: The chats are held regularly on the second Thursday of every month. You can see the link http://www.microsoft.com/windowsxp/expertzone/chats/default.mspx to see what chats are upcoming also.

    -Anurag Jain[MSFT]

  11. Fiery Kitsune says:

    Are you guys celebrating the end of support for 98SE and ME?

  12. Taichi Kamiya says:

    Could you please fix the "invalid login " problem with hotmail accounts in Outlook Express after installing beta 3 of IE7 ….

  13. EricLaw [MSFT] says:

    @ie6better: You can use a registry key to move the menu bar to the top (see enhanceie.com) and you can use group policy to remove the search box if you’d like.  We know that UI-customizability is an important feature to look at for the next version.

    @Taichi: Have you filed a bug about the problem you’re having with Hotmail?

    @Fiery: Yup, we’re looking forward to getting folks running our newer, much more secure, stable, and feature-rich operating systems.

  14. iColin says:

    I would like to submit suggestion for IE configuration settings save all/restore all…

    HP Printers have something similar and I think its a nice admin feature.

  15. Streaky says:

    Strating to feel like corporate suicide.. Lost.. All.. Will.. To.. Care.. About IE7..

    Sorry guys, I may well be one of few people to say this, but IE 7 isn’t getting any love.. Can’t make the chat, but I’m starting to wonder what you guys have actually done other than tart up the interface..

  16. PatriotB says:

    ie6better — check out some of the free browsers that are built on IE components, such as Maxthon and Avant Browser.  Most of them have much more customizability than IE.

  17. Steve says:

    Okay, now I am really starting to get annoyed!

    The latest round of Windows Updates, again, reset my default email application.

    DO NOT, UNDER ANY CIRCUMSTANCES, RESET THIS FOR ANY USER, EVER!

    If I chose to use a better email program, it is likely that I chose so, because I didn’t want to suffer with Outlook, or Outlook express!

    So when I’m forced up update Outlook, when I update windows, because I have office installed, remember that just because it is installed, does not mean you can mess with my settings.

    My default web browser, is not IE, and my default email client, is not Outlook.  I happen to be one of the millions of people you are agrevating every time you try this monopolistic approach to updates.

    Change this behaviour before MS loses even more of its respect as a software developer.

  18. Taichi Kamiya says:

    @ EricLaw [MSFT]

    no I haven’t filed the bug i was having with hotmail and ie7 beta 3, will do so today.

    Comes up as "invalid login" when I tried to check hotmail from OE6 after installinh ie7b3 – had to uninstall and revert bacsk to ie6, which has resolved the problem – OE works fine again but now no ie7 – which I’d rather have.

  19. Darleen says:

    I have been using IE 7 for about 2 weeks.  I can NOT load images on eBay and Yahoo sites.  Where the image should have loaded is a box with a little red "X" in it.

    eBay suggested that I go back to IE 6.  My question is….do I have to uninstall IE7 first????

    Thanks so much

  20. Dave Massy says:

    Darleen,

    To return to IE6 just uninstall IE7. See the notes on the support page at http://www.microsoft.com/windows/ie/support/default.mspx for details.

    If you have any extensions installed you may want to try disabling them through the add-on manager to see if that solves the image problem on those sites.

    Thanks

    -Dave

  21. Fduch says:

    Where is the chat???

  22. Dipesh says:

    Hi,

    This is not related to the current discussion out here.

    I have three frames in my page

    —————————————–

    Frame 1  |           Frame 2

            |

            |

    ———|

    Frame 3  |

            |

            |

    —————————————–

    In my frame 3 i have few links which opens displays different content on different click.

    Long story short, i am trying to change the content of frame 2 from frame3 and it works perfectly fine in Firefox. But when one of the click is not working

    i tried to use all of the following

    //              parent.frames[‘Content’].location = "http://cnn.com";”>http://cnn.com";

    //          parent.frames[‘Content’].location.replace(‘http://cnn.com‘);

    //          window.parent.frames[‘Content’].location.href = ‘http://cnn.com‘;

    //          window.parent.frames[‘Content’].location = ‘http://cnn.com‘;

    It is not throwing any error in IE but it is not functioning as it is suppose to. I am able to alert before and after executing above statements. I have used fiddler also to see whether my request is going or not but found that it is not.

    Further, i am able to display http://www.cnn.com in frame1 and frame3 but not frame 2???

    If anyone has any idea on how to change the content of frame2 using above methods (if i m doing something wrong) or some other alternative, i would appreciate if you can share it here.

    Thanks!

  23. EricLaw [MSFT] says:

    @Dipesh: First off, make sure that you’re not causing a script error.  Tools | Internet Options | Advanced.  Uncheck "Disable script debugging" and check "Show a message about each script error".

    If the page is public, please provide a URL.

    Did you consider just using normal <A> tags with the TARGET attribute set to the name of the target frame?

  24. Dipesh says:

    Hi Eric,

    First of all thanks for replying.

    I have tried the above setting changes (I was already showing script error message and then i have unchecked "Disable script debugging (Internet Explorer) as well as (others)) but still there is no real error.

    Unfortunately the page is not public so I can not send you URL but I can explain you the details of what is happening.

    (Please refer to my frame structure in my preivious entry)

    /**

    I am able to call frame1 and display content in it from frame3. Further, i am able to display the same content in frame3 but i don’t know I am not able to access frame2 from frame3.

    —————————————–

    Frame 1  |           Frame 2

            |

            |

    ———|

    Frame 3  |

            |

            |

    —————————————–

    In my page, i am using it like this.

    In my frame 3 there are two links for each table and there are many tables .

    In each of the link i open a page in the frame area 2.

    On first click => i open page1 by this construct

    parent.frames[‘Content’].location = "url of the page1 i m opening" => This works

    On second clik =? i open page2 in frame area 2

    I have some AJAX logic for that click. And i check whether i have clicked on page1 and if i have clicked it then i use the following construct

    parent.frames[‘Content’].location.replace("url of page2)

    I have also tried to use

    parent.frames[‘Content’].location = "url of the page2" ==> This does not work

    If i have not clicked on page1 then i use the following

    parent.frames[‘Content’].function1(param1, param2); => This works fine if i don’t click page1 link and keep hitting page2 link for each table in my frame3.  But when i click on page1 link and click on page2 link, for the first time it comes in the if block where i have checked whether first page was clicked or not and then nothing happens. If i click page2 link again then i get javascript error which is obivous as i m displaying page1 in my contentFrame and there is no page2 there yet and hitting it second time calls function of page2 which it won’t find and throw an error.

    Since i have links for page2 and page1 in each of the table in my frame, when i click on links for page1 for each table it works but switching from page1 to page2 is erroneous

    */

    I hope i am able to explain my problem to you. I tried to trace my http request using fiddler (live http header like tool for IE) but request it not going.

    Further, I have tested the same code in IE7 (beta 3) and it works perfectly fine. I don’t know where I am goofing but the same code is working fine in IE7, firefox,(i have not tested other browsers but can and see why this is happening)

    I am not using target attribute because I don’t want to reload the whole page again and using AJAX calls to get data for the page.

  25. Dipesh says:

    Hi Eric,

    First of all thanks for replying.

    I have tried the above setting changes (I was already showing script error message and then i have unchecked "Disable script debugging (Internet Explorer) as well as (others)) but still there is no real error.

    Unfortunately the page is not public so I can not send you URL but I can explain you the details of what is happening.

    (Please refer to my frame structure in my preivious entry)

    /**

    I am able to call frame1 and display content in it from frame3. Further, i am able to display the same content in frame3 but i don’t know I am not able to access frame2 from frame3.

    —————————————–

    Frame 1  |           Frame 2

            |

            |

    ———|

    Frame 3  |

            |

            |

    —————————————–

    In my page, i am using it like this.

    In my frame 3 there are two links for each table and there are many tables .

    In each of the link i open a page in the frame area 2.

    On first click => i open page1 by this construct

    parent.frames[‘Content’].location = "url of the page1 i m opening" => This works

    On second clik =? i open page2 in frame area 2

    I have some AJAX logic for that click. And i check whether i have clicked on page1 and if i have clicked it then i use the following construct

    parent.frames[‘Content’].location.replace("url of page2)

    I have also tried to use

    parent.frames[‘Content’].location = "url of the page2" ==> This does not work

    If i have not clicked on page1 then i use the following

    parent.frames[‘Content’].function1(param1, param2); => This works fine if i don’t click page1 link and keep hitting page2 link for each table in my frame3.  But when i click on page1 link and click on page2 link, for the first time it comes in the if block where i have checked whether first page was clicked or not and then nothing happens. If i click page2 link again then i get javascript error which is obivous as i m displaying page1 in my contentFrame and there is no page2 there yet and hitting it second time calls function of page2 which it won’t find and throw an error.

    Since i have links for page2 and page1 in each of the table in my frame, when i click on links for page1 for each table it works but switching from page1 to page2 is erroneous

    */

    I hope i am able to explain my problem to you. I tried to trace my http request using fiddler (live http header like tool for IE) but request it not going.

    Further, I have tested the same code in IE7 (beta 3) and it works perfectly fine. I don’t know where I am goofing but the same code is working fine in IE7, firefox,(i have not tested other browsers but can and see why this is happening)

    I am not using target attribute because I don’t want to reload the whole page again and using AJAX calls to get data for the page.

  26. chenoarose60@yahoo.com says:

    my yahoo don’t work at all i would like to know if anybody elses my mail works but my yahoo messenger  don’t at all i tryed to sign in  over and over again but it still won’t let me on at all please let me know if yours works  or what is wrong with yahoo messenger  thank you very much

Skip to main content