Comments (33)

  1. Anil says:

    Is it possible that I can use two DNS from the same domain to configure sharepoint apps?

    eg.

    sharepoint.contoso.com  [sharepoint collab sites]

    sharepointapps.contoso.com [sharepoint apps]

    If needed is there any workaround?

    Thanks in advance

  2. @Anil

    Yes you can. As long as they are two different DNS, you should be fine.

  3. Tommy says:

    Hi

    we have our intranet and mysite on port 80. then creating a new webapplication its complaing about the portis

    Sorry, something went wrong

    The IIS Web Site you have selected is in use by SharePoint. You must select another port or hostname.

  4. Anwarali Hajwane says:

    Hi Tommy,

    I am not entirely sure about the host headers, but I believe we can have only one web applicaiton running on one port. So you may want to choose another port for your new web application. Note that your new web application can be created over port 80 and be running, but your intranet/my site (running on port 80) will have to be "stopped" (from IIS) then. However, I assume you do not expect this to happen. So, new port would be your option. Hope this helps.

    Regards,

    Anwar

  5. Shane says:

    Ahmed, thank you for posting this article. I do have a question. I'm assuming when you say "Also it’s important to note that if you plan to publish your SharePoint app into the SharePoint store to make some money the above mentioned types (Hosted & provider hosted) are the only allowed ones as long as they don’t request full control permission", that is only because autohosted apps aren't supported yet, but when they become supported, we can charge for those apps, is that correct? Or are you saying that Microsoft will never allow autohosted apps to be charged for?

  6. @Shane. Correct. Right now Autohosted app have tenant dependencies that prevent them from being available as a platform for apps in the market place. I don't see why that can change in the feature. This is my personal opinion and nothing official from Microsoft.

  7. Armen Kirakosyan says:

    5+ for the article, thanks

  8. Mohamed Derhalli says:

    Great step by step guidance

  9. Deployment Error-Auto Hosted App says:

    While debugging it is working fine,but When I try to deploy the SharePoint auto hosted app I am getting the error – Correlation Id: 4e2aa7aa-00be-4a4f-83bb-362a567c0e21

    ErrorDetail: The remote hosting service is not configured.

    ErrorType: Configuration

    ErrorTypeName: Configuration

    ExceptionMessage:

    Microsoft.Office.SecureStoreService.Server.SecureStoreServiceTargetApplicationNotFoundException:

    Target application not found (application id:

    __RemoteAppManagementInfo__).

  10. SharePoint app is not redirecting to app domain says:

    I have configured app domain and able to ping also . I have configured the app management and subscription setting service applications . I have configured the App Catalog URL also .

    After deploying the sharepoint app in to the app catalog site , I am facing the below issue.

    The host name resolution (DNS lookup) for this host name ( ) has failed. The Internet address may be misspelled or obsolete, the host (  ) may be temporarily unavailable, or the DNS server may be unresponsive.

    Please check the spelling of the Internet address entered. If it is correct, try this request later.

    Please help to solve this issue

  11. richard says:

    I'm sorry, but this is ridiculous. ..

    I know SharePoint since SP2007 and I am always amazed how fast you are evolving with every new release, especially from a dev-perspective. Of course you can now argue that this will bring some SP2007-nostalgic, but it really feels like a drag to me

  12. Suhaib says:

    Hi Ahmad, thx for the great detailed article

    but as i noticed here, you only explained the sharepoint hosted app model, what about the on-premises model

    what do i need for the second server (app server)

  13. Jenkins NS says:

    Could please guide me

    How to get IP Address and Subnet mask from the provider APPs SharePoint 2013 Claims Token

    As per our client requirement, we need to restrict authorization(Limited access) for all users when they access the Apps from home/internet.

    Note : No AAM(Alternate access mapping)

  14. Roman says:

    This is the greatest article on this subject! i've spent some time trying to prepare my SP installation for developing SP apps and this is tricky! here i've found all the info i needed.

    Thanks a lot!!!

  15. Inderjeet Singh Jaggi says:

    Nice work buddy lot of details information which i was looking for

  16. Anthony says:

    I'm getting an error when running the powershell script  $appSubSvc = New-SPSubscriptionSettingsServiceApplication  â€“ApplicationPool $appPoolSubSvc –Name SettingsServiceApp  â€“DatabaseName <SettingsServiceDB>

    Any sugestions? I don't see anything in the logs except what I have below but I'm not even sure that has anything to do with this but it's the only unexpected items.

    Any help would be greatly appreciated

    04/16/2014 15:47:32.05 w3wp.exe (0x0734)                       0x0AE8 SharePoint Foundation         DistributedCache               ah24w Unexpected Unexpected Exception in SPDistributedCachePointerWrapper::InitializeDataCacheFactory for usage 'DistributedLogonTokenCache' – Exception 'Microsoft.ApplicationServer.Caching.DataCacheException: ErrorCode<ERRCA0017>:SubStatus<ES0006>:There is a temporary failure. Please retry later. (One or more specified cache servers are unavailable, which could be caused by busy network or servers. For on-premises cache clusters, also verify the following conditions. Ensure that security permission has been granted for this client account, and check that the AppFabric Caching Service is allowed through the firewall on all cache hosts. Also the MaxBufferSize on the server must be greater than or equal to the serialized object size sent from the client.). Additional Information : The client was trying to co…

    04/16/2014 15:47:32.05* w3wp.exe (0x0734)                       0x0AE8 SharePoint Foundation         DistributedCache               ah24w Unexpected …mmunicate with the server : net.tcp://USCUYVIIS001:22233     at Microsoft.ApplicationServer.Caching.DataCache.ThrowException(ResponseBody respBody, RequestBody reqBody)     at Microsoft.ApplicationServer.Caching.DataCacheFactory.GetCacheProperties(RequestBody request, IClientChannel channel)     at Microsoft.ApplicationServer.Caching.DataCacheFactory.GetCache(String cacheName)     at Microsoft.SharePoint.DistributedCaching.SPDistributedCachePointerWrapper.InitializeDataCacheFactory()'.

  17. sivakumar says:

    HI this blog is very useful for configuring app in sharepoint 2013.

    But i am having one more issue after configuring and deploying app to site .

    When i click to open app in browser ,it is asking credentials,but even though i am providing admin credentials,it is not accepting.

    Because of this i am not able to open app that i have developed.

    Kindly can any body share how to resolve this issue .

  18. Ahmed Farag says:

    @sivakumar: Check your Alternate Access Mapping settings

  19. sivakumar says:

    Thanks for your quick response.

    can you please give some more clear information where i have to chnage Access Mapping setting.

    Beacuse in visual studio i have tried what you earlier only but i am facing same issue.

    If there is some other option can share with me.

  20. Ahmed Farag says:

    I don't know the details of your setup but its common to see the prompt issue when you are missing an alternate access mapping record

  21. sivakumar says:

    I tried, but i am not able to resolve the issue.

    I followed same blog for configuring app in sharepoint 2013.

    But when i click on app i am not able to open .

  22. DTMumbai says:

    If any of you are facing issue of login credential window being prompted again and again, when you click on an App and even after providing credentials it doesn't work then following is the solution,

    1. Click on Start -> Run and type regedit.

    2. Locate the key 3. HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlLsa

    4. Right click on this key and choose New > DWord Value

    5. Name this one "DisableLoopbackCheck"

    6. Double-click then on it and type the value “1”

    7. Reboot your server. (Mostly not required)

    This helped me in resolving the issue.

    From Abbas – sharepointchick.com/…/setting-up-your-app-domain-for-sharepoint-2013.aspx  (Link to solution provided by Abbas)

    Thank you Abbas

  23. jshea says:

    What should the site url be if you are trying to create an app in Visual Studio?

  24. Daniel says:

    Hi Ahmed,

    deploying SharePoint Hosted Apps after configuring SharePoint 2013 after this guide worked without problems.

    The problem appears with Provider Hosted Apps.

    The Apps can't get any SharePoint Context or other Tokens throwing me a 401 not authorized exception.

    My guess is that authentification with SharePoint is not properly configured.

    Du you have any ideas?

    Thanks in advance

    Daniel

  25. Amit Kumar says:

    I am also facing this type of problem.  If u got solution please help me for this

  26. Bobby says:

    I am almost there but stuck with 404 error

    server error in ' /  ' application

    How to fix this

    Thanks

  27. Shahid Riaz says:

    Hi Ahmad Farag,

    Thanks for this article.

    I am trying to configure Sharepoint dev environment in a Virtual machine and I have installed windows server 2012 and Sharepoint many times and then uninstalled because I am not able to configure Isolated Sharepoint App environment.

    I am not good in configuration, so can you help me regarding following very basic questions?

    1) I have installed window server 2012. Now should go for this option first? "Promote this server to a domain controller?"

    2)In this article you are assigning some IP to your domains. What IP should I assign? I mean is there any specific place which I can open to see that what IP should I assign?

    Please help me.

  28. Doug says:

    Hi Amand Farag,

    Is it possible to configure appdomain without modifying DNS . I do not have access to the DNS server

    is it possible to modify host headers , please share some light

  29. Tharani says:

    Hi ,

    Initially i got the error while deploying my sample APP , it shows "Error 1 Error occurred in deployment step 'Install app for SharePoint': Failed to install app for SharePoint. Please see the output window for details" . After reading this blog i did "Install-SPFeature Applockdown" in powershell , it created but again i redeployed it shows the same error as i got earlier. Please Help me

    Thanks in advance

  30. Mubashar says:

    I tried adding value in registry as mentioned by DTMumbai but still i am facing issue of asking credentials again and again and nothing happens when i run my app.  Please help.

  31. PRawls says:

    I have followed the steps as instructed, however, I am still getting the following error in VS 2013: Error occurred in deployment step 'Install app for SharePoint': App Management Shared Service Proxy is not installed.

    I have checked and made sure everything is running and installed.

    Please help.

  32. Ahmed Farag says:

    @PRawls Your issue is related to the "App Management" Service Application. Can you remove that service application and then create a new one from the Central Admin?

  33. sharepoint says:

    to interact with sharepointprojects in visual studio the system user account must have administrative privilege.i am getting this error how to solve this