ClickOnce Application Launch Issues



1)An Error occurred during writing to the disk. Please check that disk is not full


 


-On Vista machine C:\Document and settings\<User>\Local settings\Apps this folder dint have Administrators under Security.


Most probably User Profile issue. create New user profile to resolve the issue.


 


 2) IE doesn’t recognize MIME (.application) for ClickOnce
Message : .application “Unknown MIME Type” , You want to save the file or Cancel


 


-Provide Registry permission through SubInACL tool to overcome IE issue


 


3) Office assemblies to integrate to Outlook fails during Deployment With ClickOnce
 Strong name signature not valid for this assembly stdole.dll


 


-Office assemblies should not be distributed randomly. Either PIA should be installed on target machine or added as prerequisite to ClickOnce Project


 


4) ClickOnce Launch second time gives Error


The remote server returned an error: (401) Unauthorized on ClickOnce application


 


- Application was getting Launched from Shortcut - shortcut was available at
C:\Documents and Settings\USER.HM\Application Data\Microsoft\Internet Explorer\Quick Launch\ Track-It! 8 Technician Client (2).appref-ms


 


-Add-on for IE was not allowing Launch from shortcut. Create fresh shortcut from Application Exe (located inside ClickOnce Cache) would resolve the issue


 


5) ClickOnce application doesn’t launch on client machine (No Error)


 


- Proventia Desktop and Kingston Mouse Driver would not allow Clickonce to run on the machine. There are other known Application as well.


 


6)Client cannot launch the application, Error : Store metadata "AppType" is not valid


 


- Issue is as follows:
DFSVC.exe (ClickOnce service) makes a call into System.Deployment.Application.ComponentStore.GetPropertyAppType

which then calls System.UInt16.Parse
appTypeStr in this case is "0" which is a valid string for the number 0. However, we're getting the following exception:

System.FormatException
 Input string was not in a correct format


 


This is Known issue and Working Fix is available at KB 942460

Skip to main content