The good MGA question and how to post it.


Posting a good WGA question – a how-to guide, with the reasons behind the requests!

 

Background:

There are two acronyms which I tend to use almost interchangeably – WGA (Windows Genuine Advantage) and MGA (Microsoft Genuine Advantage). Both refer to Microsoft’s technologies and surrounding procedures to reduce the level of pirated software on the market and in use. The technology is built in to most Microsoft software, and like all things manmade, it can go worng (sic.). When it does go wrong in the case of Windows XP/Vista/7, help is available in the appropriate TechNet Forums (as well as in the MS Community forums and other third-party forums such as sevenforums.com and sysnative.com).

I’ve been answering questions in the MGA forums since early 2010, and now have over 10,000 MGA threads under my belt in the TechNet forums alone. In that time I’ve seen a lot of very badly-phrased questions, a lot with insufficient data, and very few that have everything needed in the Original Post (OP – which can also mean the person who made the Original Post).

Asking a question in a forum sounds simple – and it is, if you follow the basic guidelines which are usually posted at the top of any forum as a ‘sticky thread’. Unfortunately, most people get to the forums by Googling and so they end up on a particular post which could be in the middle of an ancient thread which everybody has abandoned long ago – with the result that the new Original Poster (OP) is generally ignored when he adds a new post asking a question relating (or not!) to the original one.
A GOOD question always contains more information than is needed for the responder to make an intelligent/educated guess at a solution. It takes a little time to write – in the case of the MGA forums, generally no more than 5-10 minutes even at my two-finger typing speed. It’s certain to take less time than actually reading this blog post in full!
A BAD question contains at its worst, a one-sentence statement/question such as ‘my screen’s gone black and it tells me my Windows is Fake – what do I do?’. This means that any responder has to first establish the ground-rules (again!) and ask questions, when they could be helping others who have asked GOOD questions!

Asking a GOOD question in the MGA forums which I moderate is actually very simple, as MS has given us a useful simple-to use tool called MGADiag.exe which gathers a lot of the information we need into one place in a repeatable format which makes it possible to do initial diagnosis pretty quickly (most of the time!).

The MGADiag tool is downloadable from this link…. http://go.microsoft.com/fwlink/?linkid=52012

PLEASE don’t just Google/Bing 'MGADiag' and pluck a download from whatever site comes up – most of the non-MS sites that link to the tool actually link to older versions which give less information, and don’t really understand Windows 7 – let alone Windows 7SP1! Over the past few years, I hope I’ve managed to persuade MS to remove all the older versions of MGADiag that it had as downloads, and redirect their various links to the one I’ve given above. This latest version is compatible with XP(RTM/SP1/SP2/SP3), Vista (RTM/SP1/SP2) and Windows 7 (RT/SP1)

The GOOD MGA Forum Question contains at least the following information:

    • A description of what happened immediately before you first noticed the ‘Non-genuine notification’ pop-up on your screen – and its exact wording. This can sometimes be enough to make a first stab at a solution
    • The Version and Edition of Windows under discussion – preferably copied from the COA sticker on the machine’s case (or inside the battery compartment in some laptops) – it helps to confirm the data we see in the MGADiag report
    • Whether you’ve recently changed any hardware in your system – hardware changes are one of the most common causes of a license going out-of-tolerance and flagging a non-genuine status.
    • Whether you’ve reinstalled Windows in the past couple of months – and what installation media you used, and its provenance. (e.g. bought the machine or Windows from eBay, or NewEgg or wherever) – using the wrong Key /media is a very common cause of problems after a reinstall of the OS.
    • If you have tried Operator Activation – has MS tried already to fix the machine? (MS Support doesn’t actually train their people in MGA analysis until they get to Level 3 support – and most consumers never get much beyond level 1 support unless you/they are pushy!) – it helps us gauge how deep into the system we may have to dive to find a possible solution, but to be honest the normal MS first-line support are pretty useless at MGA problems!
    • Last, and MOST IMPORTANT, is the MGADiag report – preferably totally untouched. MGADiag gives us a wealth of data of which we can understand enough frequently to be able to make a first diagnosis without reading any of the supporting wordage, but the wordage is important when there are multiple causes for similar errors in the report.

How to produce the MGADiag report and post it:

  • First – download the tool and SAVE IT, preferably to your desktop, as it may need to be run a few times as the thread progresses and the responder gets you to take action on what they see in the report.
  • Double-click on the saved file to run the tool – if your machine is at default settings, it will run the tool, which will request security AND UAC permissions before proceeding. – fig 1 & fig2

MGADiag_UAC
Figure 1 - Permission request

(If you untick the ‘Always ask…’ box before clicking run, you won’t see that Security Warning popup again for MGADiag)

MGADiag_UAC2

Figure 2 - UAC Prompt

 

  • The UAC prompt
  • After a few seconds, you’ll see the following window – fig3

MGADiag_Continue

Figure 3 - the 'Continue button’

  • Click on ‘Continue’
  • This will then generate the report - but you WON’T see everything in the report yet. See Fig4

MGADiag_Copy

Figure 4 - The results and Copy button

 

  • To actually get the report into fully human-readable <cough, cough!> print you now have to click on the Copy button – fig 4, above – which places the generated data onto the invisible clipboard, from where it can be pasted into your text-reader of choice. For best results please paste it into Notepad – and save it. (Why Notepad? – because it strips out the unnecessary formatting that some other text editors insert. Pasting it into Word, for instance means that if you copy it out of Word and into the forum, the way it displays changes according to which version of Word you’re using, and what you have as the various default settings available, and it can make a total mess of the formatting!)
  • Don’t worry if you get an error at this point saying something along the lines of ‘Could not save the files…’ This simply means that the tool has hit a brick wall when it tried to save a set of files to the hard drive (often caused by non-standard permissions on the root folder). You can ignore this message completely, as 99.999% of the time the report is successfully sent to the clipboard ready for use.
  • Don’t worry about the fact that your report includes a lot of ‘Error’ messages – this is simply because the tool has to cope with a lot of variables, and it’s easier to include the errors than to attempt to sort out automatically which ones really mean anything significant. If the errors actually mean anything, it’s that the tool is functioning properly!

 

Now start your NEW thread in the appropriate MGA forum (or for Windows 8 and later, post in the appropriate Windows Community Forum - but you'll need a different tool for assistance there, the built-in Licensingdiag.exe )

Include in the post the requested data above, and anything else you think may be relevant (it’s way better to have too much data available than not enough!) and then copy/paste the entire MGADiag report from Notepad to the post. Please DO NOT use any kind of special formatting when pasting it – this can make it difficult to read the entire report without a lot of scrolling!

Now a GOTCHA!

In an effort to reduce the amount of SPAM that was being inserted into the Forums a while back, MS have introduced a requirement that new posters wait for a period of a few days for their account to be ’verified’ before being able to include hyperlinks in their posts. Every MGADiag report includes a minimum of four hyperlinks.

To get around the restriction you can do either (or both!) of the following…

  1. In Notepad, look for all the hyperlinks – there’s a group of four of them and there may be one or two others as well, depending on the license type involved – you can modify the ‘http://’ at the start of the link to read ‘hxxp://’ instead – this ‘breaks’ the link and allows it to be posted.
  2. Post a ‘verification request’ in the following forum https://social.microsoft.com/Forums/en-US/home?forum=reportabug There is a permanent Sticky thread there which is continually monitored, currently (August 2016) the thread is “Verify Your Account 36” but it may/will have changed by the time you read this!

If push comes to shove, you can delete the lines with hyperlinks in – but please, only delete those lines!

 

..and that’s all there is to posting a GOOD question!

Hopefully, your post will look something like this one... (I’ve highlighted things I specifically mention above)


Hi.

I have a problem with Activating my Windows 7 Home Premium.

The hard drive crashed about a month ago and I reinstalled Windows from a recovery disk I made from another computer with Home Premium (I hadn’t done this from my own).

After a few days, I was getting Activation reminders but I keep getting ‘This Key cannot be activated’ messages when I try.

What’s going on?

 

Here’s my MGADiag report:

Diagnostic Report (1.9.0027.0):
-----------------------------------------
Windows Validation Data-->
Validation Code: 0
Cached Online Validation Code: 0x0
Windows Product Key: *****-*****-2QWT6-HCQXJ-9YQTR
Windows Product Key Hash: PVjSC5x6njvqunmbCY3lOD7rYDo=
Windows Product ID: 00359-OEM-8992687-00007
Windows Product ID Type: 2
Windows License Type: OEM SLP
Windows OS version: 6.1.7601.2.00010300.1.0.003
ID: {B5ED9D57-79A1-4E11-8762-17CE3204822B}(3)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: Registered, 1.9.42.0
Signed By: Microsoft
Product Name: Windows 7 Home Premium
Architecture: 0x00000009
Build lab: 7601.win7sp1_gdr.140303-2144
TTS Error: 
Validation Diagnostic: 
Resolution Status: N/A

Vista WgaER Data-->

ThreatID(s): N/A, hr = 0x80070002

Version: N/A, hr = 0x80070002

Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002
 
OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002

OGA Data-->
Office Status: 109 N/A
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: B4D0AA8B-604-645_025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3
 
Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files\Internet Explorer\iexplore.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed

File Scan Data-->

Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{B5ED9D57-79A1-4E11-8762-17CE3204822B}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010300.1.0.003</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-9YQTR</PKey><PID>00359-OEM-8992687-00007</PID><PIDType>2</PIDType><SID>S-1-5-21-2025428036-2626030595-3146414242</SID><SYSTEM><Manufacturer>ASUSTeK Computer Inc.</Manufacturer><Model>K52F</Model></SYSTEM><BIOS><Manufacturer>American Megatrends Inc.</Manufacturer><Version>K52F.215</Version><SMBIOSVersion major="2" minor="6"/><Date>20110309000000.000000+000</Date></BIOS><HWID>77AA3507018400FC</HWID><UserLCID>0809</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>GMT Standard Time(GMT+00:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>_ASUS_</OEMID><OEMTableID>Notebook</OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>109</Result><Products/><Applications/></Office></Software></GenuineResults> 

Spsys.log Content: 0x80070002

Licensing Data-->
Software licensing service version: 6.1.7601.17514
Name: Windows(R) 7, HomePremium edition
Description: Windows Operating System - Windows(R) 7, OEM_SLP channel
Activation ID: d2c04e90-c3dd-4260-b0f3-f845f5d27d64
Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
Extended PID: 00359-00178-926-800007-02-1033-7600.0000-2092009
Installation ID: 107840903363944915401950572835014604610504357535490734
Processor Certificate URL: hxxp://go.microsoft.com/fwlink/?LinkID=88338
Machine Certificate URL: hxxp://go.microsoft.com/fwlink/?LinkID=88339
Use License URL: hxxp://go.microsoft.com/fwlink/?LinkID=88341
Product Key Certificate URL: hxxp://go.microsoft.com/fwlink/?LinkID=88340
Partial Product Key: 9YQTR
License Status: Initial grace period
Time remaining: 3330 minute(s) (2 day(s))
Remaining Windows rearm count: 2
Trusted time: 13/07/2014 15:08:09
 
Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: 0x00000000
HealthStatus: 0x0000000000000000
Event Time Stamp: 6:6:2014 13:18
ActiveX: Registered, Version: 7.1.7600.16395
Admin Service: Registered, Version: 7.1.7600.16395
HealthStatus Bitmask Output:

HWID Data-->
HWID Hash Current: OAAAAAMAAQABAAIAAQABAAAABAABAAEAln0++tIpCWpONAAXQNnOcJ4E3ogUL2LCAJCC/vg/XF0=

OEM Activation 1.0 Data-->
N/A

OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes
Windows marker version: 0x20001
OEMID and OEMTableID Consistent: yes
BIOS Information: 
 ACPI Table Name OEMID Value OEMTableID Value
 APIC _ASUS_ Notebook
 FACP _ASUS_ Notebook
 DBGP _ASUS_ Notebook
 HPET _ASUS_ Notebook
 MCFG _ASUS_ Notebook
 ECDT _ASUS_ Notebook
 SLIC _ASUS_ Notebook
 SSDT PmRef CpuPm

 


In the (artificially-created) case above, the wordage gives enough background to the history to point at a particular area of the MGADiag report – and the data there tells us that the probability is that the ‘Recovery media’ created from the other machine was not the correct one for this machine, so the mismatch causes the OEM_SLP self-activation to fail. The responder would therefore advise changing the Product Key to the one from the COA sticker. This should allow normal activation to proceed.

Time taken for the Original Post – about 10 minutes

Time for the responder to read the OP and post the suggestion – about 3 minutes

Assuming the response is the correct one, the OP replies taking about another 10 minutes (running another MGADiag report and posting that is usually enough) for the post and about 10 minutes to run the fix.

The responder should then either suggest another fix if there are still problems, or confirm that everything is OK. – about 3 minute

Assuming this is right first time around, then it takes the OP a total of 30mins, and the responder a total of 6 minutes.

With the wrong or not enough information in the Original Post, the time needed by the responder can rise dramatically – and every response from the OP takes another 10minutes. I have had to spend half an hour attempting to get the necessary information from an OP through a number of exchanges, when I could have perhaps assisted another 5 people in that time – and by the end, I was certainly less inclined to give of my best to the OP.

 

I hope this little post – which took me about 3 hours to write – manages to help anyone posting with an MGA problem – and the basic principles also apply to many other forums as well.

Happy Posting!
-Noel
p.s.

Remember

A GOOD QUESTION ALWAYS GETS A QUICKER ANSWER – if there’s an answer to be had at all!

Comments (2)

  1. This is fantastic! Is this information stickied in the MGA forums yet?

    This is a common problem, where it takes 5+ tries just to where the OP will give enough information to actually answer the question.

    Thanks, Noel!

  2. pituach says:

    Well done Noel!
    Ed mentioned 5 attempts to understand the question... I have seen more then 10 even 🙁

    A good answer depend first of all on a good question - every consultant know that firstly we need to ask the right question in the right way, in order to get the right answer 🙂

    * You should post a link to this blog from the relevant forums...

Skip to main content