ClusterCodeVersion can only be changed when UpgradeMode is set to ‘Manual’


ISSUE: When trying to upgrade the Service Fabric Version, encountered the error "ClusterCodeVersion can only be changed when UpgradeMode is set to 'Manual'"

The UpgradeMode was set to Manual in the ARM template. We were still seeing the error.

CAUSE: UpgradeMode is only supported in API Version 2016-09-01 and higher. Make sure that the API Version used in the ARM template is 2016-09-01 and higher.

Sample working REST API call:

https://management.azure.com/subscriptions/{Subscription ID}/resourcegroups/{ResourceGroup}/providers/Microsoft.ServiceFabric/clusters/{Cluster}?api-version=2016-09-01

Comments (0)

Skip to main content