Indexing Exchange Server 2007 Public Folders


I’ve had several questions recently about how to index Exchange Server 2007 Public Folders with SharePoint Server 2007.

Unfortunately with the RTM versions of both products it’s not actually possible due a couple of issues with both Exchange Server 2007 and SharePoint Server 2007.

The good news however, is that everything is back in working order if you install Exchange Server 2007 Service Pack 1 *and* your SharePoint Server also has Service Pack 1 installed.

The RTM versions of Search Server 2008 and Search Server 2008 Express are unaffected (As they already include the Service Pack 1 changes), so providing Exchange Server 2007 has Service Pack 1 installed they will both work.

None of this affects Exchange Server 2003 which works with the RTM versions SharePoint Server 2007, Search Server 2008 and Search Server 2008 Express and SharePoint Server 2007 with SP1.

Hopefully this stops people scratching their heads…

Richard Riley
Senior Technical Product Manager
Microsoft Corp.

Comments (10)

  1. Phil says:

    Hi, I see that they have now said this is working but give no instructions on how to implement it!!

    Given that Exchange 2007 still only allows access to Public Folders through the OWA (rather than through a dedicated /public URL as in 2003), how can Sharepoint 2007 be configured to crawl it

  2. You can configure it exactly the same way by using the format http://<exchangeservername>/public/<folderpath&gt;

    Hope this helps.  Rich.

  3. René says:

    I get an error in the crawllog if I try to index https://server/public/foldername

    rbs://server/public/foldername

    Ausnahme von HRESULT: 0xC004800A

    Any idea on this one?

    René

  4. Can you email me through the email link.

    Thanks, Rich.

  5. Otto Schobert says:

    Hi,

    i also have a problem crawling exchange server 2003 pf. Is there a tutorial somewhere? Thanks…

  6. Phil Marsden says:

    I have a similar problem in that when trying to use

    http://server/public/foldername

    (a) sharepoint reports an error and

    (b) I cannot open the URL in a browser

    I get a 404 error in the browser Sharepoint reports "

    "The object was not found. (The item was deleted because it was either not found or the crawler was denied access to it.)"

    Is there any documentation on knowlegebase on how this works as my Exchange server has no "public" virtual web site so I cant see how it can be accessed.

    Does sharepoint some how know the URL is an Exchange public folder and use some other method?  That would explain why you cant get to the URL in a browser

  7. Phil – can you check you have Exchange Server 2007 SP1 installed?

  8. Gordon says:

    What about indexing all of Exchange (not just PFs) for compliance purposes – is this something that Search Server 2008 can do?  I know there are a few 3rd party solutions so I’m just seeing if the MSFT product can accomplish the same thing.  Thanks

  9. Microsoft’s FAST ESP can do that via the Exchange Connector.  It supports billions of items.

Skip to main content