Expression Blend and Silverlight


Since the launch of DreamSpark I have had one or two queries about which version of Expression Blend you need to build Silverlight applications...

The only version of Expression Blend that has been fully released is v1 (available free to students through DreamSpark). However v1 does not support the creation of Silverlight applications (hence no Silverlight project type). In fact v1 is used to create WPF (3.0) applications only.

Expression Blend v2 is in beta and is (currently) available for free here. This version will allow you to build Silverlight 1.0 (JavaScript) and WPF (3.0/3.5) applications.

Finally Expression Blend 2.5 March 2008 Preview will allow you to build Silverlight 1.0 (JavaScript), Silverlight 2 (.NET) and WPF (3.0/3.5) applications and is also (currently) available free here. This is currently my weapon of choice.

There is a page on the Expression Web site that outlines Blend versioning but it is not all that easy to find.

image

Skip to main content