Error Aplicando SP2 de SQL Server 2008


Cuando se intenta actualizar una instancia de SQL Server 2008 a SQL Server 2008 Service Pack 2 en un sistema que sólo contiene el perfil de cliente del .Net Framework 4.0, es posible que la instalación falle con el siguiente mensaje de error:

SQL Server 2008 Setup requires Microsoft .NET Framework 4.0 to be installed.

Download and install .NET framework from http://www.microsoft.com/net and then rerun Setup.

Una imagen adjunta del mensaje de error es provista:

Cuando se examina el Sqlsetup.log localizado en el folder temporal (%temp%) puedes ver entradas similares a las descritas.

01/21/2011 11:01:37.415 Checking to see if we need to install .Net version 4.0
01/21/2011 11:01:37.427 Determining the cluster status of the local machine.
01/21/2011 11:01:37.442 The local machine is not configured as a cluster node.
01/21/2011 11:01:37.455 Attempting to find media for .Net version 4.0
01/21/2011 11:01:38.020 .Net version 4.0 needs to be installed from media: c:\2fbc8508d49676c919cb309810466807\
01/21/2011 11:01:38.032 Error: Unable to find media for .Net version 4.0
01/21/2011 11:12:31.114 Setup closed with exit code: 0x84C40007

Por que sucede?

Cuando el archivo de instalación de SQL server detecta el cliente de .Net Framework 4.0 en el sistema redirecciona a CLR para que cargue librerías adicionales que sólamente se encuentran si el cliente de .NET framework completo es instalado.

Como resolverlo?

Instala la versión completa del .NET Framework 4.0 de la siguiente dirección e intenta después la instalación del Service Pack de SQL.

.NET Framework 4.0 Completo

Fuente: KB2500042

Saludos

Comments (2)

  1. luisnike19 says:

    La descripción del error es muy obvia. Se necesita instalar el Framework 4.0. Al empezar a leer el artículo pensé que la respuesta sería algo más extraordinario.

  2. Francisco G. Hillyer says:

    Hola Luisnike19

    Gracias por tu comentario, así es, la respuesta es muy obvia, pero la razón de ser de éste artículo es por que existen elevadas consultas al respecto, hay quienes confunden el cliente del framework 4 con el framework completo, y cuando revisan su sistema y ven el "cliente" piensan que cumplen con los requisitos.

    De igual forma nos agrada este tipo de comentarios ya que nuestro trabajo no pasa desapercibido.

    Saludos

Skip to main content