Microsoft Forecaster – SP5 now available!

To cap off a great week talking with customers and partners at Convergence 2013 in New Orleans, we are happy to announce the release of Microsoft Forecaster 7.0 SP5. This service pack addresses issues surrounding Human Resources and Revenue as well as other product issues.

For more information and to download Service Pack 5, visit Microsoft Forecaster Service Pack 5 site.

Comments (7)

  1. kesm0724 says:

    We've installed SP5 to Forecaster on our Windows XP SP3 machines but are receiving an error: forecaster.exe is not a valid win32 application.  The application worked prior to installing SP5.  It appears this is a known issue – is there a workaround?

  2. Can you tell me if Forecaster supported in 64 bit environments? We have some client work to do and cannot find documentation on this.

  3. CharG says:

    Yes, Forecaster is supported on 64 bit.

  4. Amit says:

    "Forecaster.exe is not a valid Win32 application"  after running SP5 on version7

    Windows2003 server 32 bit.

    If any one has solution , please let us know.

  5. DAVIDTRE says:

    Amit, this error has been recorded as issue 489618 which affects Windows Server 2003 and Windows XP. Unfortunately there is not a workaround at this time. Please contact Support for further information.

  6. Still an issue says:

    Is there a 32 bit version yet?

  7. Geoff James says:

    Hi Jill,

    Does Forecaster support Windows server 2012 R2 and SQL 2012?


    Geoff James