"Error HRESULT E_FAIL has been returned from a call to a COM component" using TFS201 Team Web Access


Following comes from Senior Support Engineer Nitish Nagpal.

 

Problem:
One of my customers was facing an issue with the TFS2010 Team Web Access in a collection that  was ported over from another TFS 2010 install. They were not experiencing this issue with newly created projects on their server. While trying to edit a query in Team Web Access (TWA), they got the following error message: “Error HRESULT E_FAIL has been returned from a call to a COM component.”

This issue arises when:
1. They try to create a new work item – user story, bug, task etc.
2. They try to edit an existing query.
3. They try to open a work item from a query result set.
4. They search for a work item by the WI ID.

Troubleshooting:
Customer tried clearing team system web access cache, and they also tried to re-stamp the cache by invoking the StampWorkItemCache  by using the following URL but it didn’t work


Comments (3)

  1. KMoraz says:

    Thanks, I had this issue too and this solution worked perfectly.

  2. Connor says:

    Hi

    I've had a problem too on my Roxio game cap hd pro it comes up saying the same thing when I try and upload it to YouTube what's happened and what do I do about it.  

  3. J says:

     I am getting this error when ever I try to save my project. I am doing a "Picture Viewer" tutorial and have followed the instructions exactly, except that i get HRESULT E_FAIL has been returned from a call to a COM component. I am not getting it when I try to make anything, just save.