Exchange Server 2010 News & Reviews..


Exchange Server 2010 Reviews

Microsoft Exchange 2010 Beta Looks Solid from Core to Cloud (and related slideshow Microsoft Exchange Server 2010 Includes Welcome Improvements) – eWeek

First look: Exchange 2010 beta shines – InfoWorld

Exchange Server 2010 News

Broader Office 14 testing coming by fall – CNet

Next Exchange features e-mail ‘mute’ button – CNet

Microsoft Brands Office 2010, Releases Exchange Beta – PC World / IDG

Microsoft fends off Google with Web browser-friendly Exchange 2010 – Computerworld

Microsoft to release Exchange 2010 beta on April 15 – ZDNet

Microsoft Exchange 2010 to address annoyances & mobility – Seattle PI

Next version of Microsoft Office coming in 2010 – AP

It’s Office 2010: First technical previews due in Q3 – BetaNews

Comments (6)

  1. Congratulations – this will be a very exciting release. Thank goodness the cat is finally out of the bag on this…   I really love the new OWA.

  2. Yeah it seemed to take its time.  ..I think E2010 is going to be a good one.

  3. Jens says:

    Yes, this looks like it will be good.

  4. raavi.kishore@hotmail.com says:

    When I try to install Exchange server 2010, after finishing the installation and while running "searching for On-Premises Exchange server" I’m seeing the following error. please help me

    The following error occurred when searching for On-Premises Exchange Server:

    Connecting to remote server failed with the following error mesage:The WinRM client connot process the request. It cannot determine the content type of HTTP response from the destincation computer. The content type is absent or invalid. For more informaiton, see the about_Remote_troubleshooting help topic. It was running the command ‘Discover-ExchangeServer -UseWIA $true -SuppressError $true’about_Remote_troubleshooting help topic. It was running the command ‘Discover ExchangeServer UseWIA $true SuppressError $true’

  5. raavi.kishore@hotmail.com says:

    When I try to install Exchange server 2010, after finishing the installation and while running "searching for On-Premises Exchange server" I’m seeing the following error. please help me

    The following error occurred when searching for On-Premises Exchange Server:

    Connecting to remote server failed with the following error mesage:The WinRM client connot process the request. It cannot determine the content type of HTTP response from the destincation computer. The content type is absent or invalid. For more informaiton, see the about_Remote_troubleshooting help topic. It was running the command ‘Discover-ExchangeServer -UseWIA $true -SuppressError $true’about_Remote_troubleshooting help topic. It was running the command ‘Discover ExchangeServer UseWIA $true SuppressError $true’

  6. cartier247 says:

    Do you know if Microsoft plans on getting rid of public folders in MS Exchange in the future?

Skip to main content