Microsoft .NET Framework 4.7 is available on Windows Update, WSUS, and MU Catalog

Last Updated: 9/14/2017

We are happy to announce the Microsoft .NET Framework 4.7 is now available on Windows Update, Windows Server Update Services (WSUS), and the Microsoft Update (MU) Catalog for the following operating systems:

Client platforms: Windows 7 SP1, Windows 8.1, Windows 10 Anniversary Update (Version 1607)
Server platforms: Windows Server 2008 R2 SP1, Windows Server 2012, Windows Server 2012 R2 and Windows Server 2016

Here’s are the Knowledge Base Article numbers for the WU/WSUS/Catalog release:

.NET 4.7 Redistributable:

  • .NET Framework 4.7 for Windows 7/Windows Server 2008 R2: KB3186497
  • .NET Framework 4.7 for Windows Server 2012: KB3186505
  • .NET Framework 4.7 for Windows 8.1/Windows Server 2012 R2: KB3186539
  • .NET Framework 4.7 for Windows 10 Version 1607/Windows Server 2016: KB3186568

.NET 4.7 Language Pack:

  • .NET Framework 4.7 Language Packs for Windows 7/ Windows Server 2008 R2: KB3186499
  • .NET Framework 4.7 Language Packs for Windows Server 2012: KB4015882
  • .NET Framework 4.7 Language Packs for Windows 8.1/Windows Server 2012 R2: KB3186606
  • .NET Framework 4.7 Language Packs for Windows 10 Version 1607/Windows Server 2016: KB3186607

An offline installer is available for the same platforms. The .NET Framework 4.7 is included in the Windows 10 Creators Update.

Update on September 14, 2017, for Windows 10 LTSB and Windows Server 2016:

We recently updated the offering for following .NET Framework 4.7 Windows Update bundles for Windows 10 Version 1607 and Windows Server 2016. The .NET Framework 4.7 will no longer be offered through Automatic Updates or actively available on the WSUS channel for computers on Windows Long-Term Servicing Branch (LTSB), including both Windows 10 LTSB clients and Windows Server 2016. There is no change for other Windows non-LTSB computers.

  • .NET Framework 4.7 for Windows 10 Version 1607/Windows Server 2016: KB3186568
  • .NET Framework 4.7 Language Packs for Windows 10 Version 1607/Windows Server 2016: KB3186607

Windows 10 LTSB clients and Windows Server 2016-based computers can still install the .NET Framework 4.7 from the Microsoft Download Center. On the Microsoft Update Catalog, we have also provided new .NET Framework 4.7 Windows Update bundles specifically for LTSB computers to allow enterprises to import the updates. There is no difference in the underlying package, but the new bundles only apply to LTSB computers.

 

How is this release available?

Automatic Updates

.NET 4.7 is being offered as a Recommended update. At this time we’re throttling the release similar to what we have done with previous .NET Framework releases. Over the next few weeks we will be closely watching install telemetry and your feedback about any regressions or other issues and based on these we will slowly open up throttling.

While the release is throttled, you can use the Check for updates feature to get .NET Framework 4.7.

Note: throttled updates are offered at a lower priority than unthrottled updates, so if you have other Recommended or Critical updates pending those will be offered before this update.

Once we open up throttling, in most cases you will get the 4.7 update with no further action necessary. If you have modified your AU settings to notify but not install you should see a notification in the system tray about this update.

The deployment will be rolled out to various geographies globally over several weeks. So, if you do not get the update offered on the first day and do not want to wait until the update is offered, you can use the Check for updates feature, as described above.

Windows Server Update Services (WSUS) and Catalog

WSUS administrators will see this update in their WSUS admin console. The update is also available in the MU Catalog for download and deployment.

When you synchronize your WSUS server with Microsoft Update server (or use the Microsoft Update Catalog site for importing updates), you will see the updates for .NET Framework 4.7 published for each platform.

More Information

.NET 4.7 DirectX dependency

The .NET Framework 4.7 update for Windows 7 SP1, Windows Server 2008 R2 SP1 and Windows Server 2012 require the DirectX dependency (%windir%\system32\d3dcompiler_47.dll) to be present before .NET 4.7 will be offered to the PC. This ensures that the PC is never in the situation where .NET 4.7 is present without the DirectX dependency satisfied since that would be a broken/unsupported state.

On a related note, the DirectX dependency is available in the June 2017 Monthly Rollup as a Recommended update under the following Knowledge Base Articles:

The DirectX dependency is also available outside of the Monthly Rollup as an independent/standalone package in the Microsoft Update Catalog here in case you need to install this independently.

Language Packs

In addition to the language neutral package the .NET Framework 4.7 Language Packs are also available on Windows Update. These can be used to if you have a previous language pack for .NET installed as well as if you don’t, but instead have a localized version of the base operating system or have one or more Multilingual User Interface (MUI) pack installed.

Blocking the automatic deployment of .NET 4.7

Enterprises may have client machines that connect directly to the public Windows Update servers rather than to an internal WSUS server. In such cases, an administrator may have a need to prevent the .NET Framework 4.7 from being deployed to these client machines in order to allow testing of internal applications to be completed before deployment.

In such scenarios, administrators can deploy a registry key to machines and prevent the .NET Framework 4.7 from being offered to those machines. More information about how to use this blocker registry key can be found in the following Microsoft Knowledge Base article:

KB4024204:  How to temporarily block the installation of the .NET Framework 4.7 and its corresponding language packs

 

Updated 6/19/2017: Added knowledge base article numbers for the .NET 4.7 redistributable and language packs.