How to Fix a Setup File is from a later version Error from the Support Debugging Tool


David Meego - Click for blog homepageThis issue with the Support Debugging Tool has occurred a few times recently after installing the latest version of the Support Debugging Tool.

The error message below is displayed by the Support Debugging Tool just after logging into Microsoft Dynamics GP:

Setup File is from a later version (##.##.####), please update the version (##.##.####) of the Support Debugging Tool on this workstation. 

 

This dialog is displayed when the version and build number already saved in the Support Debugging Tool’s Debugger.xml setup file is from a newer version or build than the version and build of the Support Debugging Tool dictionary currently installed on the workstation giving the error. This message was designed to ensure than once a system has been updated to a new build of the Support Debugging Tool that all workstations have the Support Debugging Tool code updated to match.

 

To resolve this issue, you need to make sure that the latest Support Debugging Tool code (Debugger.cnk and Debugger.pdf) are installed on all workstations that already have the tool installed (or preferably … all workstations in the system).

 

Also see the related articles below:

 

Hope this is useful. 

David

17-Sep-2014: Added link to article explaining steps for Test Upgrade.

Comments (1)

  1. David Musgrave says:

    Posting from Mark Polino at DynamicAccounting.net

    msdynamicsgp.blogspot.com.au/…/how-to-fix-setup-file-is-from-later.html