Office.js debug: Office add-in throws “Sorry, we couldn’t load the app because your browser version is not supported”


One of the ISV pointed out that they see the following error with Office Add-ins that they develop. It throws error “Sorry, we couldn't load the app because your browser version is not supported. Click here for a list of supported browser versions.

During the investigation we noticed the end user’s browser (Internet Explorer) is configured with some ‘customized’ settings. As part of troubleshooting, we tried the following and it helped moving forward.

- Make sure that the browser supports HTML5 local storage

- If the above doesn’t work then reset your Internet Explorer settings.

- For information about supported browsers, see Requirements for running Office Add-ins.

Hope this helps.

Comments (0)

Skip to main content