Visual Studio 2010 Beta 2 セットアップ時の Silverlight 3 SDK とのバージョン不整合について


出典はこちらです: Visual Studio 2010 and Silverlight 3 SDK


[問題] Visual Studio 2010 Beta 2 をインストールするマシンに、すでに Silverlight 3 SDK がインストールされていると、Visual Studio 2010 Beta 2 のセットアップの途中でSilverlight SDK のインストールがエラーになることがあります。


[原因] Silverlight 3 Tools for Visual Studio 2008 または Expression Blend 3 をインストールすると、Silverlight 3 SDK ビルド 3.0.40624 がインストールされます。一方 Visual Studio 2010 Beta 2 は、より新しい Silverlight 3 SDK ビルド 3.0.40818 をインストールしようとします。


[回避方法] Visual Studio 2010 Beta 2 をインストールする前に、Silverlight 3 SDK ビルド 3.0.40624 をアンインストールします。


[確認方法] Windows のコントロールパネルの [プログラムのアンインストール] から Silverlight 3 SDK のバージョンを確認します。



ちなみに現在ダウンロード センターからダウンロードおよびセットアップが可能な Silverlight 3 SDK は、最新のビルド 3.0.40818 です。

Skip to main content