InfoPath 2010 Form with Sandboxed code will not publish to a SharePoint that is also a Domain Controller


 

Receiving the following error: “The form template has been published to the server but it can only be opened in InfoPath Filler. The sandboxed solution could not be activated. The custom code in the form cannot be run. This functionality may be deactivated on the server. For more information, contact the server farm administrator.”?

First, ensure that you’re not doing something legitimately wrong by designing a new form and publishing it to a form library successfully. Then prove the negative case by adding some code, such as an empty event handler. If the publish gives you the error described, and you’re trying to deploy to a SharePoint server that is also a Domain Controller (common with development and/or investigative Proof of Concept VMs), then try the registry permission fixes described in the following KB: http://support.microsoft.com/kb/2026191. Worked like a charm for me.

 

image


Comments (3)

  1. Jeffrey McFarland says:

    I did what the article said, but it still didn't work for me. Step #3 doesn't work quite right. It says, " Click Permissions, click to select Users, click to select the Read check box in the Allow column of Permissions for Users, and then click OK." I don't have a "Users" to select. I only have "CREATOR OWNER" "Authenticated Users" …

  2. daweins says:

    That could definitely be the source of your problem… if "Users" isn't there already, then add them… click "Add", then add the users group from your local computer. Ex: if your computer name is daweins-win7 (which yours probably isn't, but mine is), then you would add the group daweins-win7Users

    then resume the instructions by granting the Users group "Read" permissions….

Skip to main content