Install WCF RIA Services v1.0 SP1 Beta – missing Silverlight 4 developer runtime?


     If you see the following dialog popping up while trying to install WCF RIA Services v1.0 SP1 Beta (via links from http://www.silverlight.net/getstarted/riaservices/), it means Silverlight 4 developer runtime is missing on your machine. The reason could be that the recent windows update have installed the newer version of Silverlight 4 plug-ins, which has overriden the older developer runtime.

To solve this issue, you need to do the following steps:

   - Go to "Program and Features", manually uninstall "Microsoft Silverlight"

   - Reinstall the most recent Silverlight 4 developer runtime by clicking this link:

http://go.microsoft.com/fwlink/?LinkID=146060

 

 Hope that helps!


Comments (0)

Skip to main content