Is it taking ages to display the gallery when you are trying to add a web part?


If you find it can sometimes take 20–30 seconds to return the web part gallery so that you can drop a web part onto a web part page then this post is for you.

The problem may be because SharePoint is trying to contact the online web part gallery, however, if your machine is not connected to the internet, or the proxy is not configured properly, then it could take some time to actually work this out. This is the delay you are seeing.  

You can easily turn off the web part gallery by following these simple steps:

1. Open SharePoint Central Administration (make sure you are on the Windows SharePoint Services page)

2. Click on “Configure Virtual Server”

3. Select the Virtual Server on which you are experiencing the delay

4. Click “Manage Security Settings for Web Part Pages”

5. Select the “Disabled” option next to “Online Web Part Gallery” and click OK.

OnlineGallery

You should now find it all working at lightning speed, I kinda wish we had shipped it this way.

Comments (13)

  1. Mart Muller says:

    Ah great, this was why my Sharepoint development Virtual PC is taking such a long time! Thanks for the tip!

  2. Patrick says:

    Definetly sounds like a place for some multithreading. Thread off those calls to the web, so that even if it fails/stalls, the UI stays responsive.

  3. Hey Patrick,

    I’m sure there would be a way to do it better, fingers crossed for the next version eh?

    As it stands its all server side, so not sure threading would help much, either way it just has to wait until it knows before sending the page down to the client.

  4. Alex says:

    Thanks so much for this tip!

  5. Oh thankyou for posting this. I knew I had seen the answer to this problem a while back inside MSFT, but when I asked around a few weeks back everyone turned stupid and couldn’t come up with a good answer. This will help me so much with my dev work.

  6. Well mine was, and it was getting embarrassing trying to explain to the customer why it was running so…

  7. Daniel McPherson posted a great tip on speeding the display of the web part page gallery.  For his…

  8. Daniel McPherson posted a great tip on speeding the display of the web part page gallery.  For his…

  9. Daniel McPherson posted a great tip on speeding the display of the web part page gallery.  For his…

  10. Daniel McPherson posted a great tip on speeding the display of the web part page gallery.  For his…

  11. Daniel McPherson posted a great tip on speeding the display of the web part page gallery.  For his…

  12. This is a quick one to speed up WSS when using it, especially when doing demos. The service by default

Skip to main content