XNA 4.0 nie jest kompatybilne wstecz


Niestety.

Pierwszy duży projekt jaki sobie napisałem w Xna GS 3.1 nie chciał się skompilować w 4.0. Po wielu godzinach zabawy zszedłem do jedynych 250 bledów spowodowanych głównie zmianami w API.

Wszystkie zmiany są opisane tutaj.

Jeśli wykorzystujecie shadery (via efekty) to przygotujcie się na zmianę każdego Begin() i End() na Apply(). Jeśli korzystaliście intensywnie z RenderState’ów to przygotujcie się na to, że zostały rozbite na wyspecjalizowane pod-kategorie.

RenderTarget2D to dopiero zabawa. Składnia podczas inicjalizacji oraz różnych parametry tego obiektu zostały kompletnie zmienione. Ta zmiana kosztowała mnie naprawdę dużo pracy, aby przywrócić jeden F/X do działania.

Nie powinno was to boleć, jeśli dopiero zaczynacie pisać pod Xna (od razu od 4.0), ale może to być bolesne przy migracji z starszych wersji.

Comments (0)

Skip to main content