Instead of the Default View ‘All Site Content’ links to List Settings

In Windows SharePoint Service v3 (WSSv3) and Microsoft Office SharePoint Server 2007 (MOSS), there is a link in the Quick Launch area of sub webs (unless it’s been hidden or disabled) titled “View All Site Content”. This link will navigate to an ASPX page in the Layouts folder called ViewLsts.aspx which is designed to show…

1

"Drives are running out of free space"…but who cares?

SharePoint Foundation 2010 and SharePoint Server 2010 introduced a pretty cool new feature of built-in health rules. These rules will monitor for commonly known issues and helps to alert you if your SharePoint farm may be experiencing issues that either are causing problems or may cause problems in the near future. For more information on…

1

URLScan intereferes with WebDav

This is by no means an all-encompassing blog entry about trouble-shooting WebDav with SharePoint, but this is a post about a single issue that I encountered and hope to help others with additionals toolsets in this area. While assisting a customer with a new SharePoint Foundation 2010 environment we were having problems getting WebDav working….

0

SharePoint Server 2010 and incoming email

I received a call from a customer last week stating that they were able to configure incoming email on some of their lists/libraries, but not on others. When pressed for details they elaborated that they had enabled it in Central Administration: however when they navigated to List/Library Settings, the option to enable incoming email under…

1

FAST Search for SharePoint Configuration Failure

One of my good friends, Cory Roberts, pinged me the other day with a problem concerning configuration of FAST Search for SharePoint 2010 (FS4SP). I had done a couple of installations so had at least *seen* it. 🙂 He had completed all of the pre-req installations and installed the product without an error. As you…

0

PowerShell caching leads to head-banging

I was attempting to repro a customer issue today and was growing more and more frustrated by the apparent problem that my code was not getting updated with each subsequent build and deployment. It turned out to be something I never would have guessed except through trial and error. The scenario is using VS 2010…

5