BizTalk 2013 R2 CU1 install failing with “Package does not contain compatible branch patch”


We’ve had a number of people run into the following issue so I just wanted to provide an explanation and solution.

 

Issue:

BizTalk 2013 R2 Cumulative Update 1 (CU1) install fails with “Package does not contain compatible branch patch” error:

 

Explanation:

This issue is happening in environments where a version of BizTalk Health Monitor (BHM) from the Microsoft Download Center has been placed within the BizTalk installation folder.

There are 2 branches of BHM:

  1. OOB BHM – shipped out-of-the-box with BTS2013 R2
  2. DLC BHM – shipped via Microsoft Download Center

OOB BHM has had 2 released versions so far.  Version 2.0.0.0 shipped with BizTalk 2013 R2 RTM and version 3.1.5632.20684 shipped with BizTalk 2013 R2 CU1.

OOB BHM is located at \SDK\Utilities\Support Tools\BizTalkHealthMonitor within the BizTalk installation folder (default installation folder is C:\Program Files (x86)\Microsoft BizTalk Server 2013 R2)

DLC BHM has had many versions and is currently at 3.1.5654.28025.

The BTS2013R2 CU1 installer throws the above mentioned error if it finds any version of BHM within the BizTalk installation folder that is not a part of the OOB BHM branch.

We have seen this issue in environments where the user did one of the following:

  1. Replaced the OOB BHM binaries in the \SDK\Utilities\Support Tools\BizTalkHealthMonitor folder with a version of DLC BHM
  2. Created a new folder with a version of DLC BHM anywhere within the BizTalk installation folder

 

Solution:

To allow CU1 to install, simply move the folder containing DLC BHM out of the BizTalk installation folder and run the installer again.

Moving forward, never place any DLC BHM version within the BizTalk installation folder.

 


Comments (0)

Skip to main content