EDI Leap Year hotfix : For BizTalk Server 2006 R2 & 2009


Hi

Here is a notofication for a critical update for fixing the Leap year issue in BizTalk Server 2006 R2 and 2009 versions.

 

Important : BizTalk Server 2006 and 2010 versions are not affected by this bug.

 

EDI Leap Year hotfix: BizTalk 2009 and BizTalk 2006 R2

 

If using EDI in BizTalk 2009 and BizTalk 2006 R2, install the EDI leap year hotfix before 2/29/12:2435900   FIX:" Invalid Date" EDI interchange error occurs in BizTalk Server 2006 R2 or in BizTalk Server 2009 if a data element contains a leap date value

 

BizTalk Server 2009:

There are two ways to get this fix:

 Option 1: Install any BizTalk 2009 Cumulative Update. KB 2555976 lists the available cumulative updates:

 

 Option 2: Install the stand-alone fix by clicking View and request hotfix downloads at the top of KB article 2435900.

 

 BizTalk Server 2006 R2

There are two ways to get this fix:

Option 1

  1. Install BizTalk 2006 R2 ServicePack 1.
  2. Install BizTalk 2006 R2 Service Pack 1 Cumulative Update 3.
  3. Install leap year fix (3.6.2230): http://support.microsoft.com/kb/2435900

PS: It is recommended to install CU3 before applying the fix as there are many other dependent binaries that get
updated and it is in the customer’s best interest to be on the latest supported
platform and minimize troubleshooting efforts.

 

Option 2

Install the stand-alone fix by clicking View and request hotfix downloads at the top of KB article 2435900.

 

Note BizTalk Server 2010 is not impacted by this bug.


Skip to main content