Query Server status always shows Error


Recently I am noticing search related issues with below symptoms.


Issue
-----------------------------------------


The Query Server under Search Administration page always shows the below 2 status


Server Status - Error
Propagation Status - Waiting for Initialization (MOSS-XYZ-WFE1)


Sometimes we also get error message in the Application log
Event Type: Error
Event Source: Office SharePoint Server
Event Category: Office Server Shared Services
Event ID: 6482
Date: DD/MM/YYYY
Time: hh:mm:ss
User: N/A
Computer: Server Name
Description:
Application Server Administration job failed for service instance Microsoft.Office.Server.Search.Administration.SearchServiceInstance (GUID).
Reason: The underlying connection was closed: An unexpected error occurred on a send.


If we receive the above error which is a good hint, then we can try the below article which contains the solution
http://support.microsoft.com/?id=962928


But what if there are no errors and still we notice the below?
Server Status - Error
Propagation Status - Waiting for Initialization (MOSS-Stage-WFE1)


Possible resolution
===============
For Issue -> Server Status - Error
Try the steps given in article http://support.microsoft.com/?id=962928


For Issue -> Propagation Status - Waiting for Initialization (MOSS-Stage-WFE1)


Try to repair MOSS installation on the problematic server.
Ran PSConfig wizard on the server.


This may resolve the issue completely.


 


Skip to main content