Double Http Issue in Destination URL when using both API and UI


 


Archived: February 25, 2008

The adCenter UI prepends an ?http://? to the DestinationURL upon Save unless you choose Keyword destination URL in the Destination URL drop down when editing an ad. So if you already have an ?http://? in Param1 for your keyword as set via the API for example, you now have two when the ad serves, and the link will be broken as it would look like http://http://company.com. There are workarounds through proper usage, however.

Here is a breakdown of the issue:

* Let?s say for ?keyword1?, the SubstParam1 value is ?http://a.com? (a perfectly valid and common usage)

* For Ad1, created via the API, the DestinationURL value is {Param1}&adlevelinfo=true (this is allowed, but not recommended. Should only contain {Param1})

* So when a user searches for ?keyword1? and the ad displays, the URL would look like http://a.com&adlevelinfo=true (a valid URL)

* But if this ad is simply opened in the UI, then saved (making no changes at all, for example), the Ad1 DestinationURL now contains ?http://{Param1}&adlevelinfo=true?

* When this ad now displays again, it will have the double http://, and be broken

Currently, this is expected behavior, and is by design.  One workaround, if you choose to use ad-level additional parameters, is to not use ?http://? in the keyword SubstParam1 field, and let the browser fill one in if it?s not there. You could update via the API or the UI without problems.  This would not work if any of your destination url?s are https (secure SSL) however, because Internet Explorer, for one, doesn?t try  https if you just type in ?a.com?, but only attempts http.

The other option is to not make any updates via the UI once the ads are placed via the adCenter API.

adCenter API Support

Comments (0)

Skip to main content