在 LightSwitch 服务器项目上启用.NET Framework 4.5


[原文发表地址]  Enabling .NET Framework 4.5 on LightSwitch Server Projects

[原文发表时间]  2013-01-23 3:17 PM

拥有了Visual Studio 2012 中的LightSwitch (也就是 LightSwitch V2) ,您的服务器项目可以指向.NET Framework 4.0。这是该团队主动的决定以此来允许 V2 应用程序被部署到运行V1 应用程序的相同服务器。此外 LightSwitch 运行时不依赖.NET 4.5,只有 4.0。

也就是说,您可能想要充分利用服务器端.NET 4.5 中的一些增强功能,所以下面是你应如何做的。请记住,这不是"官方的"支持。该团队尚未完全测试此方案,所以你从中获得的好处可能有所不同。为了在LightSwitch 中更改目标框架,您需要修改服务器项目文件。

步骤如下:

  1. 如果您有打开的 LightSwitch 解决方案,请关闭 Visual Studio
  2. 导航到您的解决方案的 \Server 文件夹
  3. 在文本编辑器 (如Notepad) 中编辑Server.vbproj (或 csproj)文件
  4. 对 <TargetFrameworkVersion> 做以下更改: <TargetFrameworkVersion> v4.5</TargetFrameworkVersion>
  5. 保存该文件,并重新打开 Visual Studio
  6. 编译 ,验证没有错误

现在,您将能够利用.NET 4.5 中的新功能。有关详细信息请参见:.NET Framework 4.5 中的新功能。请记住,您将需要部署到一个支持.NET 4.5 的服务器。请参阅.NET Framework系统要求的"受支持的服务器操作系统"部分。

希望大家喜欢 !

Skip to main content