Failed to save Auth settings Easy Auth Azure Authentication


When I tried to configure a a URL into the ALLOWED EXTERNAL REDIRECT URLS text box, as shown in Figure 1, I received the following error.

Failed to save Auth Settings for authenticated App: {"Code":"Conflict","Message":"Cannot update the site '******' because Authentication / Authorization was configured with an invalid external redirect URL '***.***.***.***'. All configured URLs must be well-formed and absolute.","Target":null,"Details":[{"Message":"Cannot update the site '*****' because Authentication / Authorization was configured with an invalid external redirect URL '***.***.***.***'. All configured URLs must be well-formed and absolute."},{"Code":"Conflict"},{"ErrorEntity":{"Code":"Conflict","Message":"Cannot update the site '*******' because Authentication / Authorization was configured with an invalid external redirect URL '***.***.***.***'. All configured URLs must be well-formed and absolute.","ExtendedCode":"04524","MessageTemplate":"Cannot update the site '{0}' because Authentication / Authorization was configured with an invalid external redirect URL '{1}'. All configured URLs must be well-formed and absolute.","Parameters":["******","********"],"InnerErrors":null}}],"Innererror":null}

The initial thought was that because the domain I was trying to add was a multi-subdomain format like:  public.admin.contoso.com that for some reason wasn’t liking that.

What I figured out, was that it needs to have HTTP/HTTPS included with the hostname.  I binged for some answer and found nothing so I then had to troubleshoot it myself and this is what I found.  So maybe by writing this one it will save them some minutes.

#EasyAuth #RedirectUrls #AzureAuthentication

image

Figure 1, Invalid external redirect URL, Azure App Service

I got a different error in the old portal…Figure 2

image

Figure 2, the reply URL must be a valid URL

Comments (0)

Skip to main content