Microsoft Dynamics AX Support

This blog contains posts by the Microsoft Dynamics AX Support Teams Worldwide

Forms authentication provider stops working after applying May CU for SharePoint 2013

After we installed May CU for SharePoint 2013 (15.0.4823.1003) we were not able to log with Forms authentication users and the error (404)

In SharePoint log we could see the error:

Exception trying get context compatibility level: System.IO.FileNotFoundException: The site https://dax2012r3.contoso.com:8090/_Layouts/FormsAuth/Login.aspx could not be found in the Web application SPWebApplication Name=DynamicsFormsSTS – dax2012r3.contoso.com-8090. at Microsoft.SharePoint.SPSite.LookupSiteInfo(SPFarm farm, Boolean contextSite, Boolean swapSchemeForPathBasedSites, Uri& requestUri, Boolean& lookupRequiredContext, Guid& applicationId, Guid& contentDatabaseId, Guid& siteId, Guid& siteSubscriptionId, SPUrlZone& zone, String& serverRelativeUrl, Boolean& hostHeaderIsSiteName, Boolean& appWebRequest, String& appHostHeaderRedirectDomain, String& appSiteDomainPrefix, String& subscriptionName, String& appSiteDomainId, Uri& primaryUri) at Microsoft.SharePoint.ApplicationRunt… …ime.SPRequestModule.GetContextCompatibilityLevel(Uri requestUri)

I have analyzed the issue and it looks like the issue was connected to the fact that when we create provider using the command:

Add-AXSharepointClaimsAuthenticationProvider

We do not create a site collection at the root and that causes the issue. Once I have created a site collection at the root where we have provider the issue got resolved.

It seems we are running into the issue described here:

https://support.microsoft.com/en-us/kb/2590564

https://blogs.technet.microsoft.com/mpriem/2012/11/07/always-have-a-root-site-collection/

To solve the issue, you need to:

  1. Go to the SharePoint 2013 Central Administration
  2. Click on Create site collection:
  3. Select the Web application which hosts you authentication provider.
  4. Create a team site collection at root location

There is also possibility to create a blank page. To create a blank page, you need to run following command in SharePoint 2013 Management Shell

$template = Get-SPWebTemplate “STS#1”

New-SPSite -Url “https://dax2012r3.contoso.com:8090” -OwnerAlias “contoso\administrator” -Template $template

(following http://www.sharepointpals.com/post/How-to-Create-a-Blank-Site-Collection-and-a-Blank-Sub-Site-on-SharePoint-2013)