Biztalk: No result returns when click the button “Run Query” in HAT [Operations -> Service Instances] or [Operations ->Messages]



Problem:


=======


 


In BizTalk 2004 SP2, no result returns when click  the button “Run Query” in HAT [Operations -> Service Instances] or [Operations ->Messages]. Some other queries in HAT such as [Queries->Message counts] still work fine. The problem begins after the .NET 2.0 is uninstalled.


 


 


Analysis:


======


Although the .NET 2.0 is uninstalled, the following registry is still existed in the system, that causes the HAT tries to locate the .NET runtime type library mscoree.tlb from the .NET 2.0 runtime folder but that file (mscoree.tlb) is removed already from the folder due to the un-installation.


 


[HKEY_CLASSES_ROOT\TypeLib\{5477469E-83B1-11D2-8B49-00A0C9B7C9C4}\2.0\0\win32]


@="C:\\WINDOWS\\Microsoft.NET\\Framework\\v2.0.50727\\mscoree.tlb"


 


 


Solution:


========


Two workarounds to fix the problem:


 


1.       Copy the .NET runtime 1.0 mscoree.tlb to the .NET 2.0 runtime folder.


 


To copy mscoree.tlb


 


From


 


C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\


 


to


 


C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\


 


2.       Remove the registry key [HKEY_CLASSES_ROOT\TypeLib\{5477469E-83B1-11D2-8B49-00A0C9B7C9C4}\2.0] from the system.


 


*note* Please back up the key before removing so that it can be restored back If there are any other errors.


 


Regards,


 


Xiao Dong Zhu


 


 


 


 


 

Comments (0)

Skip to main content