Experiencing Broken Links Issue in Alert Mails – 04/13 – Resolved


Final Update: Wednesday, 13 April 2016 13:08 UTC

We've confirmed that all systems are back to normal with no customer impact as of 4/13, 1:10 PM UTC. Our logs show the incident started on 4/12, 9:30 PM UTC and that during the 15 hours 40 minutes that it took to resolve the issue customers might have seen broken links in alerting mails which were sent during the impacted window from 9:30 PM 4/12/2016 to 9:30 AM 4/13/2016
  • Root Cause: The failure was due to recent deployment in one of our Application Insight Pipeline which has impacted the alerting mails to have broken links..
  • Lessons Learned We have collected telemetry logs and identified steps to be taken to avoid these kind of scenarios in future.
  • Incident Timeline: 15 Hours & 40 minutes - 4/12, 9:30 PM UTC through 4/13, 1:10 PM UTC

We understand that customers rely on Application Insights as a critical service and apologize for any impact this incident caused.

-Rama


Update: Wednesday, 13 April 2016 09:27 UTC

Root cause has been isolated to recent deployment in one of our Application Insight Pipeline which was impacting the alerting mails to have broken links. To address this issue we have revert back to our old deployment. Alerting mails are now working as expected. Some customers may have experienced broken links in alerting mails. We are in process of providing Hotfix to fix the broken links which were sent during the impacted window from 9:30 PM 4/12/2016 to 9:30 AM 4/13/2016
  • Work Around: None
  • Next Update: Before 04/13 13:30 UTC

-Rama


Skip to main content