Rant: TiVo seem to be losing it


I've been a happy and loyal TiVo customer for five years now, but events this week have caused me to wonder if they are losing it. On Monday my HDTivo started playing up, which is unusual for this normally pretty perfect Linux machine. When it hadnt fixed itself by Tuesday I hit the Tivo Community site, only to discover lots of other pissed HDTivo customers.

Turns out many machines that self-upgraded to the 3.1.5d firmware were having the exact same issue as me. Furthermore other users were having other serious problems with this new software. The issues seem to fall into three categories:

No control. This is the first issue I had: the device simply stops taking notice of the remote control. It can see the signal (as the led on the box flashes when I transmit), but does nothing. In addition the buttons on the front of the unit don't work either. To regain control of the box you have to pull the plug and reboot it, which is a 10 minute process.

Stuttering Video Playback: This is my second issue: on playback the video stutters, and if you try to FF or REW things get much worse quickly. This isnt a signal issue, as after a reboot the same recording will play perfectly, for a while.

Transponder problems: I didnt have this problem, but a bunch of folks are having certain transponders on the satellite just stop working, causing them to lose a bunch of their channels.

What pisses me more than the problem itself is the way DirectTV and TiVo are handling it: there is no official statement i can find anywhere, and when you call DTV (who support these boxes) to report the problems they deny anyone else has reported the same problem. The reason they do this is that they do not record tech support issues, they just listen as you report problems then do nothing. When I called back on Weds I said I was having the same problem as I reported Tuesday night, and while they could tell I had called and spoken to a supervisor, my actual problem was not recorded.

DirecTV are sending me a replacement unit, though if this is a software problem as it appears then this wont help me. It will just cost me lost time (as I re-enter 45 season passes), lost recordings (250G worth) and cost TiVo money. As a TiVo shareholder I object to DTV sending replacement hardware to users who all seem to be having the same software problems. Expect to see a lot of refurbished devices in the market in a month or so.

Thursday evening my TiVo upgraded to 3.1.5e. It made no difference for me. The rumor mill claims this does fix the transponder issue.

The real irony is that 3.1.5d contained no new features. No HMO, no Series 2, no Folders, no USB networking. Rumors claim it is purely to support the new satellite they put up. Instead it has pissed off a chunk of the TiVo community. We deserve fixes, urgently, and an explanation.

Comments (4)
  1. MichaelM says:

    I have the non-HD version and Josh (I think it was Josh at least) in 2nd level support at least ack’d the problem and said I was screwed for ~2 weeks. Luckily I have 2 directivos so I’m not out completely. Only one of my boxes had issues with the upgrade and I lost all odd transponder signals.

  2. 厚重之刀 says:

    It’s a pitty that 中国看不到 HDTivo.

  3. 厚重之刀 says:

    Sorry: "pitty" should be "pity".

Comments are closed.

Skip to main content