SQL Server cluster failover fails with Error Code: 0x80071398


I have installed a 3-node SQL Server 2012 failover cluster on Windows Server 2012 few days ago, and it has been running very well. Until today, I found that I could not manually failover the SQL cluster service from node 3 to node 1, and failed with the following information:

The operation has failed

The action 'Move' did not complete

The operation failed because either the specified cluster node is not the owner of the group, or the node is not a possible owner of the group

Here is a screenshot:

The error is a bit strange to me as I can see the Node 1 was listed there when I performed the Move operation, and the cluster installation was successfully on all 3 nodes. At this point, I did some research, and found someone mentioned that the Node 1 might be not a possible owner for one or more of SQL Server failover cluster dependencies. After several clicks, I found that the failed Node 1 was not a possible owner of IP address of SQL Server virtual server name like below, once I selected it back, the failover succeeded.

 

Hope this helps 🙂

Comments (10)

  1. Nadya says:

    Thanks a lot! This helped me to solve the same issue.

  2. HuyVo says:

    I have the same problem as you!

    You topic help me to solve.

    Thanks a lot!

  3. Igor Dryahlov says:

    Thanks!

    Problem solved.

  4. Vedhu says:

    Hi, The same issue is happening for me when I tried to move the resource manully.

    My server is windows 2008 R2. I could see the preferrec owner but i was unable to view possible owner list. Can you pls help me to found the owner and fix the issue.

  5. Bill says:

    Thank you very much! Solve my problem.

  6. Андрей says:

    Спасибо, помогло. Всё время забываю это проверять.

  7. Mike says:

    Thank you so much.  We have the same issue and this information helps solve the issue.

  8. Venkatesan says:

    I have the same problem as you!

    You topic help me to solve.

    Thanks a lot! 🙂

  9. Kevin3NF says:

    Just saved me a ton of time, thanks 🙂

  10. Buki says:

    Thank you, it solved my problem too.

Skip to main content