Q. Do i need to uninstall 3.0 in order for Visual Studio 2005 to compile 2.0 managed applications?


A. Visual Studio 2005 will target your managed appliations as 2.0 by default.  3.0 adds to the 2.0 layer and is fully backwards compatible.  For more information check out the following link:


http://msdn2.microsoft.com/en-us/netframework/aa663309.aspx


If you want to compile 3.0 projects then you will need to install the extensions for WF and Extensions for WCF/WPF:


For a full list of .NET Framework 3.0 applications, including the extensions:


http://msdn2.microsoft.com/en-us/windowsvista/aa904955.aspx


  

Comments (0)

Skip to main content